Erste Beta

  • Dieses Thema hat 49 Antworten und 6 Teilnehmer, und wurde zuletzt aktualisiert vor 9 Jahre von Anonym.
Ansicht von 15 Beiträgen - 31 bis 45 (von insgesamt 50)
  • Autor
    Beiträge
  • #1661
    Patrick
    Verwalter

    Just remembered that bot my machines here have a old Windows XP installation on their HDs. Just trying a download of the complete FS on my Notebook (now Windows XP Sp3), seems to be running fine, only 1 bad file so far.

    I’m thinking of compiling WaveBackup against .NET Framework 4, a lot of things have changes there, and i could really use some of the new features as well …..

    #1662
    KrazyKong
    Teilnehmer

    It’s worth a shot Patrick. Maybe having .NET 4 runtimes would remove some of the randomness in the failed copies bug.

    #1663
    Patrick
    Verwalter

    Ok, i’ve uploaded a .Net 4 Version and an new .Net 2 Version, so we can compare both framework versions …..

    #1665
    adfree
    Teilnehmer

    .NET 2 Version short tested… but this time 1 *.exe failed… so I stopped.
    Installed .Net Versions on my PC:
    v1.0.3705
    v1.1.4322
    v2.0.50727
    v3.0
    v3.5

    Ancient time machine 😆

    I will download .Net 4 soon and test.

    Best Regards

    #1667
    adfree
    Teilnehmer

    1.0.3 with NET 4 seems to run more stable. 😀
    ServicePack 3 was on the Card… so big file.
    Explorer part should work only with internal Memory.

    Best Regards

    #1668
    Patrick
    Verwalter

    So, uploaded a new Version for .Net 4. This time it’s tuned for speed! Fetching the complete directory listing for the phone (memorycard excluded!) took about 3 minutes for me. Haven’t tried downloading all the files yet …… will do that later when i have more time.

    #1655
    KrazyKong
    Teilnehmer

    Was hoping Patrick you might have found a way to still keep this as .NET 2 compatible. .NET 4 from what I’ve seen on my computer system leaves so many residue services and other files running even when I’m not running an app that needs them, that I’ve religiously uninstalled .NET 4 if I don’t have any apps needing it.

    Looking at adfree’s version of .NET, it occurred to me we are all probably using different versions and thus maybe why we’re getting the randomness factor. I use Microsoft .NET Framework v3.5 SP1 which contains all the latest previous versions of the .NET runtimes (v1, v2, v3 and v3.5). Patrick are you going .NET 4 for good, or is this just a test phase to iron out a few things first?

    Testing the new 1.0.4 version I for sure noticed a speed increase of the fetching. However I noticed something else here.

    To test the fetching speed, I clicked fetch all. I flew past very quickly and completed fetching all folders. Then I went to do a test copy of "AppEx". And instead of just copying, it proceeded to fetch that directory again. Once it completed this, it started copying. So there’s a double up of the fetching that needs addressing. The file copying seems stable so far and might even be speedier too.

    Also oddly on my 8500T phone, the directory listings are not sorted alphabetically. Yet on my 8500 phone they are. So would be nice if you could add some tabs up the top just like in Windows Explorer, so you can sort by name, size or date. After I did a test copy of "AppEx", then hit fetch all again, the listing changed to semi alphabetical, so there’s a randomness to how it’s displaying this. EDIT: Ok I found something here. The first initial listing is not alphabetical, but if you disconnect, reconnect, then hit fetch all, then abort right away, it then arranges the listings into alphabetical.

    Another thing, is it possible to hide or remove the extra taskbar entry/window when copying files?

    I noticed the new right click "Exclude Memory Card" option. May I suggest also adding a checkbox somewhere, maybe under or near the "Examine Application.xml…" or just anywhere on the visible options at the top of the screen.

    And finally just want to mention no errors in copying "AppEx" which I think is the first time I’ve been able to do that with WaveBackup. I did a side by side test too and both sTune and this verson of WaveBackup succeeded in copying the exact same number of files and folders, empty ones as well 😛

    #1631
    Patrick
    Verwalter

    Uploaded Version 1.0.5. This time it’s .Net 3.5. I didn’t noticed any changes in stability.
    I have added some output to gather performance benchmarks. I’ve also fixed a sorting bug in the list.

    I would use .Net 4 if it is clear that it is superior in stability compared to older version of .NET, but so far this seems not to be the case. At the moment i’m thinking of settling with 3.5 because nowadys the majority of people should have it installed.

    #1634
    KrazyKong
    Teilnehmer

    Oh awesome 🙂

    Also would it be possible to enable the column headers to sort on the List Apps page? Right now it seems to default to sorting via original folder name only. Currently they are clickable but don’t do anything yet.

    #1637
    Patrick
    Verwalter

    I think you detected all other changes i made already. I may have tweaked the serial communication a bit, but to be honest, i can’t remember exactly what i did. Column sorting in App List schould be no problem, also you’re right about that message-loop when disconnecting the phone, that’s something i should definitely fix before realeasing WaveBackup ‚officially‘.

    The next Version will be up soon, and will have some more options to play with ….

    #1623
    Patrick
    Verwalter

    New beta is up!

    #1624
    KrazyKong
    Teilnehmer

    1.0.6 is crashing for my quite majorly. Have pm’d you a log file.

    You can make it crash by starting WaveBackup, and not having the phone connected, then click on Explorer. It will bomb out instantly. The other crashes where when it was connected, and I’d be in List Apps. It would work, but then I’d come back to that tab, hit List apps again and it would instantly crash. It’s the same crashing symptom, or just exiting immediatly. No error windows or anything displayed either.

    I’m uninstalling .NET 4 currently, then will reinstall .NET 3.5 SP1. Then will test again and see if any difference.

    #1626
    Patrick
    Verwalter

    Fixed the bugs you’ve reported. Version 1.0.7 is up.
    Did a lot of major internal changes tha last days, so this might not be over yet ….

    #1627
    adfree
    Teilnehmer

    1.0.7 looks very nice. 😎

    Runs without problems now. Except that I’ve removed Asphalt 5 and not copy from Card.

    I will try more times… then report again, if something changed.

    Thanx.

    Best Regards

    #1628
    Anonym
    Inaktiv

    Thankisssssssssssssssssssssssssssssssss

Ansicht von 15 Beiträgen - 31 bis 45 (von insgesamt 50)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.