Datum aus EXIF und Änderungsdatum von RAW

Startseite Foren www.mortara.org Software WIA-Loader Datum aus EXIF und Änderungsdatum von RAW

Dieses Thema enthält 7 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Patrick vor 8 Jahre, 3 Monate.

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #1640

    jph
    Teilnehmer

    Ich möchte Raws (CR2) und jpgs jeweils in ein Verzeichnis Datum/JPG/Datum_Dateiname und Datum/RAW/Datum_Dateiname schreiben lassen.

    Bei jpgs funktioniert es, bei CR2-RAW hat es mal vor einigen Versionen funktioniert, und zwar in der Version, als es die Option "Dateien mit gleichen Namen gruppieren" noch nicht gab.

    Jetzt habe ich Version 1.7. ganz frisch aus dem Netz und quälte mich einen Nachmittag lang.

    Problem 1:
    bei den RAWs (Canon, CR2) hat WIA das Dateidatum auf Heute umgeschossen.
    Mit EXIFTOOL hab ichs repariert (FileModifyDate as EXIF:DateTimeOriginal)
    Im Anschluss kann akzeptiert WIA aber weder mit
    <PDATE> noch mit
    <DATE>
    das reparierte Dateidatum (Explorer zeigt, dass es repariert ist).

    Problem 2:
    <EXIF:CREATEDATE> oder <EXIFTOOL:CREATEDATE> oder <EXIFTOOL:36867> funktioniert nicht. Der Dateinmae wird zu [EXIFTOOL_36867][EXIFTOOL_DATETIMEORIGINAL] [EXIFTOOL_CREATEDATE] usw., das Datum steht also nicht im Dateiname.

    WIALoader 1.7
    Exiftool 8.47
    WinXP

    Bin mit den Nerven am Ende. 🙁
    Bitte um Hilfe!

    MFG JPH

    #1641

    jph
    Teilnehmer

    ..und Wunsch wäre dann beim EXIFDatum:
    YYY_MM_DD\RAW\YYYY_MM_DD_hhmmss_Dateiname..

    #1642

    Patrick
    Keymaster

    Hallo,

    schau bitte mal in den Einstellungen, bei ‚Dateitypen‘, was dort für Cr2 angeklickt ist.

    Welche Werte du mit EXIF: und EXIFTOOL: auslesen kannst, siehst du am einfachsten, wenn du dir die ‚eigenschaften‘ bzw. exiftool eigenschaften‘ eines der Bilder in der Vorschau anzeigen lässt. Dort werden alle verfügbaren Werte aufgelistet.

    Patrick

    #1643

    jph
    Teilnehmer

    Hallo,

    danke für die Antwort.

    Patrick wrote:

    Hallo,
    schau bitte mal in den Einstellungen, bei ‚Dateitypen‘, was dort für Cr2 angeklickt ist.
    Patrick

    angeklickt ist: Eingebettet, .NET3, Shell-API. Typ ist Image.

    Patrick wrote:

    Welche Werte du mit EXIF: und EXIFTOOL: auslesen kannst, siehst du am einfachsten, wenn du dir die ‚eigenschaften‘ bzw. exiftool eigenschaften‘ eines der Bilder in der Vorschau anzeigen lässt. Dort werden alle verfügbaren Werte aufgelistet.
    Patrick

    OK, gemacht.
    -EXIF-Daten-Tabelle ist leer für CR2, nicht aber für jpg.
    -Exiftool-Tabelle zeigt die EXIF-Daten. Ich kann sie nun mit der kopierten Syntax <EXIFTOOL:EXIF:DateTimeOriginal> übertragen – super, ein Fortschritt.

    Aber wie macht man dann die Formatierung in yyyy_mm_dd ?

    MFG JPH

    #1644

    jph
    Teilnehmer

    ..und im WIA Vorschaufenster links (Quelldateien) wird das Datum der CR2-Dateien ebenfalls nicht "richtig" wie im Explorer / wie mir EXIF-GUI korrigiert angezeigt, gleiches "falsches" Datum wie PDATE…

    Noch ein Rätsel von PDATE, das vielleicht auf dem gleichen Fehler beruht:
    Hatte übrigens früher auch mal eine Abweichung um eine Stunde festgestellt zwischen PDATE und der Explorer-Dateizeit, möglicherweise Sommer/Winterzeit? Trat bei JPG und CR2 auf.

    MFG JPH

    #1645

    Patrick
    Keymaster

    Kannst du für cr2 Dateien das Canon SDK aktivieren, oder wird das in Rot dargestellt?

    Für die Formatierung von Datumsvariablen, wirf mal einen Blick hier rein:
    http://www.mortara.org/media/wialoader/&nbsp;… ablen.html

    #1620

    jph
    Teilnehmer

    Patrick wrote:

    Kannst du für cr2 Dateien das Canon SDK aktivieren, oder wird das in Rot dargestellt?

    SDK läßt sich aktivieren unter DATEITYPEN.
    Damit funktioniert dann auch PDATE. Super, das ist schon mal toll! 😛

    Die Datumsvariablenformatierung klappt ja mit Pdate nach dieser Hilfeseite, NICHT ABER mit Exiftool.
    Konkrete Beispiele:

    (1) 2011_01_01
    (2) 2011_01_01__11_14_22

    PDate-Syntax wäre
    (1)<Pdate:yy_mm_dd>
    (2)<Pdate:yy_mm_dd__hh_mm_ss>

    Gleiche Syntax mit EXIFTOOL ergibt Mist, nämlich
    (1) <EXIFTOOL:EXIF:DateTimeOriginal:yyyy_mm_dd> ergibt
    2011_01_01 11_14_22 !

    Bitte konkret, wie sollte EXIFTOOL-Befehlsyntax lauten für (1) und (2) ?

    #1651

    Patrick
    Keymaster

    Du hast Recht, das geht so scheinbar nicht. ExifTool meldet WIA-Loader dieses Feld als ‚String‘ Feld, und nicht als Datum, deswegen gehen die Datumsformatierer dann nicht. Was du versuchen kannst, ist die Uhrzeit abzuschneiden:

    <EXIFTOOL:EXIF:DateTimeOriginal:|-9>

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.