Kein doppelter Import

Startseite Foren www.mortara.org Software WIA-Loader Kein doppelter Import

Dieses Thema enthält 7 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Patrick vor 9 Jahre, 5 Monate.

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #1397

    heiner76
    Teilnehmer

    Hallo,

    das Programm bietet für den erfahrenen Benutzer eine Vielzahl von Möglichkeiten. Was ich jedoch noch nicht hinbekomme ist folgendes:

    Wenn nach dem Import der Zielordner zur Verbesserung des Überblicks umbenannt wird, zum Beispiel von "2010_01_15" in "2010_01_15 Produktfoto", wird beim nächsten Import der Ordner "2010_01_15" neu erstellt und die Fotos von diesem Tag landen doppelt auf der Festplatte.

    Da das Programm ja eigentlich sämtliche Kopiervorgänge mitloggt, sollte es doch möglich sein, bereits kopierte Dateien vom erneuten Kopieren auszuschließen. Hab ich da eine Einstellung übersehen?

    Falls das nicht funktioniert, wäre es ja vielleicht eine Anregung für zukünftige Versionen. Sonst finde ich das Programm super.

    Beste Grüße

    Henry

    P.S.: Wie bekomme ich die mitgelieferten Importprofile dauerhaft gelöscht? Hab sie im programm entfernt und sogar im Einstellungsordner gelöscht, aber irgendwie werden sie immer wieder neu angelegt.

    #1398

    Patrick
    Keymaster

    Damit sich WIA-Loader die Import-Vorgänge dauerhaft merkt, muss im Import-Schritt der Haken bei ‚Vorgang in Datenbank speichern‘ gesetzt sein. Dann sollte es auch kein Problem sein, wenn man die Ordner nachher umbenennt. Ich werde das nachher selbst mal austesten.

    Die Profile befinden sich eigenlich nur im Programmordner, also dort wo WIA-Loader installiert wurde, im Unterordner SampleProfiles, und im ordner der für Einstellungen benutzt wird. Wenn man sie dort überall löscht, sollten sie eigentlich nicht wieder kommen.

    #1399

    heiner76
    Teilnehmer

    Hallo,

    danke für die schnelle Antwort. Der Haken ‚Vorgang in Datenbank speichern‘ ist bei mir gesetzt. Der Ordner wird trotzdem immer wieder neu erzeugt.

    Die Sampel-Profile hab ich erfolgreich entfernt.

    Grüße

    Henry

    #1400

    Patrick
    Keymaster

    Setzt WIA-Loader denn bei den bereits importierten Bildern die Häkchen in der Vorschau? Vielleicht liegt ja da das Problem. Der ganze ‚Trick‘ basiert ja darauf, dass WIA-Loader die Häkchen bei den Bildern entfernt, die schon einmal importiert wurden. Wenn aus irgendeinem Grund die Häkchen vor dem Import gesetzt werden, werden dementsprechend auch die Ordner usw. wieder angelegt.

    #1401

    heiner76
    Teilnehmer

    Ich hab das Häkchen bei automatischer Import entfernt und trotzdem werden die Bilder sofort kopiert… ich kann also gar nicht sagen, ob Häkchen zu sehen sind oder nicht. Der Import läuft sofort los.

    #1402

    Patrick
    Keymaster

    Wo genau hast du diesen Haken entfernt? Unter Einstellungen->Geräte ?

    #1403

    heiner76
    Teilnehmer

    Kann nicht mehr nachsehen. Programm stürzt beim Aufbau der Vorschau immer wieder ab. Hab schon neu installiert, auch den Einstellungsordner in den Anwendungsdaten gelöscht. Geht nicht mehr. Keine Ahnung woran es liegt. Gibt es noch einen Ort wo Einstellungen gespeichert werden?

    #1404

    Patrick
    Keymaster

    Ja, das .NET Framework speichert bestimmte Programm Einstellungen nochmal an einem anderen Ort ab. Aber den krieg ich jetzt nicht so ganz zusammen. Ist irgendwo unter ‚Dokumente und Einstellungen\Benutzername\Lokale Einstellungen‘.

    Ich glaube, es ist einfacher, wenn du mir dein Logfile schickst, und ich versuche den Fehler zu finden. Ein ’normaler‘ Programmabsturz müsste da eigentlich zu finden sein.

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.