Fragen zu Suffix

Startseite Foren www.mortara.org Software WIA-Loader Fragen zu Suffix

Dieses Thema enthält 4 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  bhb vor 7 Jahre, 10 Monate.

Ansicht von 5 Beiträgen - 1 bis 5 (von insgesamt 5)
  • Autor
    Beiträge
  • #1781

    bhb
    Teilnehmer

    Hallo,

    ich benutze das Programm schon einige Zeit und kann nur lobend erwähnen, dass es seinen Zweck erfüllt!!!

    Nun habe ich ein kleineres Probelm und benötige Hilfe:
    Ich nehme mit einer Digicam Bilder im Highspeedmodus auf. Die Bilder werden auf der Karte im Format IMG_xxx.jpg abgespeichert. (xxx ist eine fortlaufende Nummer).
    Mit Hilfe von WIALoader will ich die Dateien mit folgender Namensgebung abspeichern:
    "2011_08_05-13h_45m_55s_yyy.jpg"
    2011=Jahr // 08=Monat // 05=Tag //
    13=Uhrzeit mit Suffix "h" // 45=Minute mit Suffix "m" // 55=Sekunde mit Suffix "s" //
    yyy =Suffix mit fortlaufender Nummer beginnend z.B. mit 000.
    Dieser Suffix soll die Bilder, die den gleichen Zeitstempel haben, hochzählen.

    Ist dies mit WIALoader möglich?
    Ich habe es mit der portablen Version 1.7.2.0 probiert und ist mir leider nicht gelungen.
    Ich habe den Eindruck, dass die Einstellung "Konflikt-Handling – Bild mit Suffix speichern" nicht ordnungsgemäß funktioniert. Vielleicht habe ich auch etwas falsch gemacht.

    Vorab Danke.

    Gruß
    bhb

    #1782

    Patrick
    Keymaster

    Hallo,

    wie werden denn die Bilder gespeichert, wenn die Option ‚Mit Suffix Speichern‘ ausgewählt ist?

    Patrick

    #1783

    bhb
    Teilnehmer

    Hallo Patrick,

    ich habe folgendes Testszenario:
    Von gleichem Bild habe ich 2 Kopien erstellt: IMG000.jpg (das Original), IMG000_01.jpg, IMG000_02.jpg
    D.h. alle Bilder haben den gleichen Zeitstempel.
    Ich verwende die protable Version V1.7.2.0.

    Einstellungen / Vorschau/Import
    -Default für Datumsformat= yyyy-MM
    -Default für Uhrzeiten= HH"h-"mm"m-"ss"s"
    -Default für Zahlen= 000

    Einstellungen / Iport Profile
    -Drehen / Exif Feld 274/Orientierung = angewählt
    -Bild speichern / Verzechnis anlegen = <PDATE:yyyy-MM>
    -Bild speichern / Dateinamen ändern= <PDATE:yyyy_MM_dd>_<PTIME>
    -Konflikt handeln / Bild mit Sufix speichern= angewält
    -Konflikt handeln / Suffix für erste Datei nutzen = angewählt
    -Konflikt handeln / Formatierung= 000

    Das Ergebnis ist nun folgendes:
    – Verzeichnis 2011-08 wurde angelegt
    – in obiges Verzeichnis wurde nur eine (1) Datei gespeichert: 2011_08_09_20h-03m-48s.jpg
    – in der Vorschau wird der Suffix auch nicht angezeigt

    Meine Erwartungshaltung wäre folgende gewesen:
    2011_08_09_20h-03m-48s_000.jpg
    2011_08_09_20h-03m-48s_001.jpg
    2011_08_09_20h-03m-48s_001.jpg

    Oder habe ich die Funktion missverstanden?

    Vielen Dank für die schnelle Reaktion!!

    Gruß
    Benno

    #1784

    Patrick
    Keymaster

    Das Konflikthandling macht einen Byte-Vergleich, und wenn die Dateien identisch sind, wird nicht nochmal versucht, sie zu speichern. Du müsstest für deinen Test also unterschiedliche Bilder nehmen.

    #1785

    bhb
    Teilnehmer

    Hallo Patrick,

    es funktioniert – es lag tatsächlich am binären Vergleich.

    Eines ist mir noch aufgefallen:
    In der "Import Vorschau" werden die Dateien entsprechend farblich gekennzeichnet, aber der Suffix im Dateinamen wird nicht angezeigt. Ich würde es für gut befinden, wenn dieser zusätzlich zur farblichen Kennzeichnung in der Liste auch angezeigt wird (evtl über eine Checkbox wählbar). Entsprechender Hinweis im Tootip wäre super.

    Nochmals Danke für den Hinweis.

    Gruß
    Benno

Ansicht von 5 Beiträgen - 1 bis 5 (von insgesamt 5)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.